Change youtube embeds to use iframe or youtube api
Posted on Wed Jul 15, 2015 11:34 pm

avatar

Uldred

Indie Artist
Indie Artist
I don't know if you have the technical know-how to do it but flash has recently had many vulnerabilities so it's blocked in ff by default (I personally always use the html5 version anyways), so could you change it to use the html5 embed instead?

https://i.imgur.com/C1VQPvV.png

also flash always crashes for me...
https://developers.google.com/youtube/player_parameters

here's some more info on it:
https://developers.google.com/youtube/player_parameters
https://developers.google.com/youtube/iframe_api_reference#Loading_a_Video_Player

I think their iframe embed is an "intelligent" version and uses the google account settings.

The youtube api version is more complicated imo

Back to top Go down

Re: Change youtube embeds to use iframe or youtube api
Posted on Thu Jul 16, 2015 12:38 am


Scandalsuki

Mainstream Artist
Mainstream Artist
Uldred wrote:I don't know if you have the technical know-how to do it but flash has recently had many vulnerabilities so it's blocked in ff by default (I personally always use the html5 version anyways)
You must update flash manually if you get that issue. Just had that problem yesterday on two pcs, updating flash fixed it.

Back to top Go down

Re: Change youtube embeds to use iframe or youtube api
Posted on Thu Jul 16, 2015 10:39 am

avatar

Uldred

Indie Artist
Indie Artist
Scandalsuki wrote:
Uldred wrote:I don't know if you have the technical know-how to do it but flash has recently had many vulnerabilities so it's blocked in ff by default (I personally always use the html5 version anyways)
You must update flash manually if you get that issue. Just had that problem yesterday on two pcs, updating flash fixed it.

with the number of vulnerabilities flash has had in the past 2 weeks I'd rather just leave it disabled... it's even blocked by default in firefox now

Back to top Go down
avatar

Plutonium

International Performer
International Performer
Flash has been re-instated by Mozilla today because Adobe fixed the vulnerabilities.



Back to top Go down

Re: Change youtube embeds to use iframe or youtube api
Posted on Fri Jul 17, 2015 12:28 pm

avatar

Uldred

Indie Artist
Indie Artist
Plutonium wrote:Flash has been re-instated by Mozilla today because Adobe fixed the vulnerabilities.
How long until crash player has another vulnerability?

anyways it's alright, I'll just write a userscript to change the embed for myself

Back to top Go down
avatar

Jikan

Indie Artist
Indie Artist
https://jikan.fr/
I second Uldred's suggestion. Flash is one of the world's worst piece of software ever. It's just a matter of time before new critical flaws are discovered, let alone all the 0-day remaining undisclosed.
That being said, I'm not sure Forumotion would allow such config changes, but it's worth to check.




「私は完璧を嫌悪する!! 完璧であるば、それ以上は無い。」
「そこに創造の余地は無く、それは知恵も才能も立ち入る隙がないと言う事だ」
If a link I posted is dead, I probably just moved the file to another account or replaced it with a better version. Feel free to PM me.
IRC
Back to top Go down